Platform outage
Incident Report for Riipen
Postmortem

This outage was caused by Riipen’s reliance on the Stripe.js v3 CDN.

This package is dynamically pulled into Riipen at system run-time via <script src="https://js.stripe.com/v3/"</script>>.

Unfortunately Stripe does not provide any sort of versioned history of this file. The maintain a single “live” version which we must pull in on page load. In this particular outage, Stripe made a change to this package’s script which conflicted with any web platform built with webpack using its code splitting features. In particular, Stripe overwrote the window.webpackJsonp variable to be non compatible with webpack.

As Riipen’s automated platform infrastructure was not affected by this outage, but rather customers visiting the website experienced a local issue, Riipen was unable to automatically detect this event. However, Riipen’s error detection system for client side errors experienced a larger volume of errors which led our team to investigate the production site and thus discovered the issue.

Our status page was promptly updated while we waited for Stripe to fix the issue on their end.

Posted Oct 02, 2019 - 21:59 PDT

Resolved
Stripe has resolved the issue on their end and the Riipen platform is back online.
Posted Oct 01, 2019 - 15:58 PDT
Identified
The issue has been identified as an issue with Riipen'a payment processor Stripe. We are in contact with them and will continue to update as needed.
Posted Oct 01, 2019 - 15:56 PDT
Investigating
We are currently experiencing an outage. We are investigating and will update with further details.
Posted Oct 01, 2019 - 15:38 PDT
This incident affected: Platform.